A SERVICE OF

logo

Simple VRF-lite configuration examples
Page 32 | Configure VRF-lite
interface vlan1
ip vrf forwarding red
ip address 192.168.10.1/24
!
interface vlan2
ip vrf forwarding green
ip address 192.168.20.1/24
!
interface vlan3
ip vrf forwarding shared
ip address 192.168.30.1/24
!
router ospf 1 red
network 192.168.10.0/24 area 0
redistribute bgp
!
router ospf 2 green
network 192.168.20.0/24 area 0
redistribute bgp
!
router bgp 100
address-family ipv4 vrf red
redistribute ospf
redistribute connected
exit-address-family
!
address-family ipv4 vrf green
redistribute ospf
redistribute connected
exit-address-family
!
address-family ipv4 vrf shared
redistribute static
redistribute connected
exit-address-family
!
ip route vrf shared 192.168.33.0/24 192.168.30.3
ip route vrf shared 192.168.34.0/24 192.168.30.3
ip route vrf shared 192.168.35.0/24 192.168.30.3
!
route-map red33 permit 1
match ip address redBlock3435
!
route-map green35 permit 1
match ip address greenBlock3334
!
line con 0
line vty 0 4
!
end